Home > Arch Linux > Arch Linux Keyboard Not Working In X

Arch Linux Keyboard Not Working In X

Contents

First remove the keyboard/mouse drivers: Code: pacman -Rd xf86-input-keyboard xf86-input-mouse Then reinstalling the evdev driver like this: Code: pacman -S xf86-input-evdev you might get a error since that's what I had XkbOptions contains some extra options. Next thing is to automatically connect to the Internet when the system boots. Arch Linux HomePackagesForumsWikiBugsAURDownload Index Rules Search Register Login You are not logged in. Check This Out

if you want to quickly switch between layouts. Before to start it we have to create the /root/.xinitrc file (indeed we need that file in the $HOME of every user starting the X) with the following contents: # Make You are currently viewing LQ as a guest. Email check failed, please try again Sorry, your blog cannot share posts by email. %d bloggers like this: https://bbs.archlinux.org/viewtopic.php?id=114882

Arch Linux Keyboard Layout

Forums Quick Links Arch Packages AUR Bugs Download Linux Reddits Linux Linux Questions Linux4noobs Linux Multi Documentation Installation Guide ArchWiki Community Mailing Lists IRC Channels Planet Arch International Communities a community Tried reinstalling xorg-server-utils and xf-86-input-evdev didn't help, there were no errors. As I adhere to the ‘keep it simple' philosophy of Arch Linux my choice was the LXDE. vitorsgoncalves View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by vitorsgoncalves 03-12-2012, 11:08 AM #2 SilentSam Member Registered: Aug 2007 Location: Ottawa

vitorsgoncalves View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by vitorsgoncalves 03-13-2012, 10:06 AM #13 SilentSam Member Registered: Aug 2007 Location: Ottawa MathSciNet review alert? I've switched mirrors, and now one problem is solved -- Xorg actually logs stuff now.http://dpaste.com/488540/Though it crashes when I try to start it. Xkboptions This behaviour stems from typewriters.

If that doesn't work, try forcing a reinstall on hal like this: Code: pacman -Sf hal and configure xorg once again as root: Code: X -configure cp /root/xorg.conf.new /etc/X11.xorg.conf Then start now xinput outputs: ⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ SYN1B7F:01 06CB:2970 UNKNOWN id=12 [slave pointer (2)] ⎣ I already read that post: "http://www.linuxquestions.org/questions/arch-29/no-keys-no-mouse-933764/", it seems like the same problem, but don't want to reinstall the system. No synaptics driver loaded?” after reboot.

The syntax of X configuration files is explained in Xorg#Configuration. Localectl Offline #8 2011-03-11 19:18:56 YAOMTC Member Registered: 2010-02-23 Posts: 171 Re: Keyboard and mouse not working in X / X crashes [SOLVED] Thanks a lot, thn81! These files will be automatically included in the sudoers file every time the sudo command is issued. A couple things didn't work like the mkfs -F32 step but you can get around those.

X11 Keyboard Layout

If you need to reset your password, click here. https://archlinuxarm.org/forum/viewtopic.php?f=31&t=2940&start=10 SilentSam View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by SilentSam 03-13-2012, 10:58 AM #14 vitorsgoncalves Member Registered: Mar 2010 Posts: 96 Arch Linux Keyboard Layout Then half day in arch linux and finally spent two minutes only to make it run after I did follow instructions here what to put into .xinitrc. Error Loading New Keyboard Description vitorsgoncalves View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by vitorsgoncalves 03-12-2012, 03:07 PM #12 vitorsgoncalves Member Registered: Mar 2010 Posts: 96

how does xcolor's \color work? his comment is here Also systemd's localectl can be used to define the keyboard layout for both the Xorg server and the virtual console. You won't be able to vote or comment. 456Keyboard and mouse not working in X (self.archlinux)submitted 2 years ago by MiniukovMy keyboard and mouse stopped working in x. Registration is quick, simple and absolutely free. Setxkbmap Options

regarding the 50-synaptics.conf I simply deleted it from /etc/X11/xorg.conf.d/ and restarted systemctl stop/start lxdm.service (budgie desktop) and everything started working again share|improve this answer answered Jul 16 at 12:32 gstlouis 11 This will make the Shift+NumLock shortcut toggle mouse keys. Tip: XIM is very old, you might have better luck with other input methods: SCIM, uim, IBus etc. this contact form If you have one check /etc/X11/xorg.conf.d/ Also try reinstalling xorg-server-utils and watch especially for xf86-input-evdev permalinkembedsavegive gold[–]Miniukov[S] 0 points1 point2 points 2 years ago(7 children)I deleted xorg config to check if default would

In my case (Spanish layout) I have to run the command: # localectl set-keymap --no-convert es which set the value of the KEYMAP variable in the /etc/vconsole.conf file: KEYMAP=es This configuration Arch Linux Keymap List Please help me out. After last upgrade, my keyboard and mouse (both PS/2) stop working after system boot, making the system totally unusable.

Multiple layouts may be specified in a comma-separated list, e.g.

Very unlikely to be causing your issue. Introduction to Linux - A Hands on Guide This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started What happened? Xkb Keycodes Configuring compose key Though typically not on traditional keyboards, a Compose key can be configured to an existent key.

The Rupee sign (₹) can be used the same way with rupeesign:4. I'm not sure if this will work, but you should be able to chroot your Arch drive and get the package list. Coworker throwing cigarettes out of a car, I criticized it and now HR is involved more hot questions question feed about us tour help blog chat data legal privacy policy work http://emhsoft.net/arch-linux/arch-linux-suspend-not-working.php EDIT: Depending on when this issue occurred for you could it have something to do with: https://www.archlinux.org/news/xorg-server-116-is-now-available/ EDIT2: I really wouldn't worry about xkbcomp showing warnings.

After checking that time synchronization works fine we can go to the next task: adding a new user. This can be fixed by forcing GTK to use XIM by adding export GTK_IM_MODULE=xim and/or export XMODIFIERS="@im=none" to ~/.xprofile. Unix & Linux Stack Exchange works best with JavaScript enabled Main menu Skip to primary content Quick Start Downloads Buy Codecs Forum FAQs About About us Contact us Technical, help and See man localectl for more information.

My cat sat on my laptop, now the right side of my keyboard types the wrong characters Why can curcumin cross the blood-brain barrier, but not congo red? To see a full list of keyboard models, layouts, variants and options, along with a short description, open /usr/share/X11/xkb/rules/base.lst. This can also be done by binding a key to Terminate_Server in xmodmap (which undoes any existing XkbOptions setting). I need help figuring out why, as nothing I've done in the past few hours has fixed it.

You can get more information about this topic here and here.